<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width,initial-scale=1.0">
<link rel="pingback" href="https://nerdvanamedia.com/xmlrpc.php">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="NOUp4wBupi86Qe_D2oIUl9vUw6HHtKaTE0gANWS35tA" />
<meta name="msvalidate.01" content="D89E637D044DD326B5C2FDC67A2B157A" />
<meta name="yandex-verification" content="af97dae0726e0842" />

	<!-- This site is optimized with the Yoast SEO plugin v17.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Deborah Ann Woll leads Jack Black and more through D&amp;D&#039;s Lost Odyssey: Promised Gold</title>
	<meta name="description" content="Lost Odyssey: Promised Gold will have fans catching up with the adventures of Jack Black after the end of his last D&amp;D adventure ..." />
	<link rel="canonical" href="https://nerdvanamedia.com/gaming/deborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold/156686/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Deborah Ann Woll leads Jack Black and more through D&amp;D&#039;s Lost Odyssey: Promised Gold" />
	<meta property="og:description" content="Lost Odyssey: Promised Gold will have fans catching up with the adventures of Jack Black after the end of his last D&amp;D adventure ..." />
	<meta property="og:url" content="https://nerdvanamedia.com/gaming/deborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold/156686/" />
	<meta property="og:site_name" content="Nerdvana" />
	<meta property="article:publisher" content="http://www.facebook.com/nerdvanablog" />
	<meta property="article:author" content="https://www.facebook.com/jaysonpeters" />
	<meta property="article:published_time" content="2021-12-17T14:00:00+00:00" />
	<meta property="article:modified_time" content="2021-12-17T17:17:55+00:00" />
	<meta property="og:image" content="https://nerdvanamedia.com/wp-content/uploads/2021/12/lost-odyssey-crop.jpg" />
	<meta property="og:image:width" content="1213" />
	<meta property="og:image:height" content="683" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@https://twitter.com/jaysonpeters" />
	<meta name="twitter:site" content="@nerdvana" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jayson Peters" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel="alternate" type="application/rss+xml" title="Nerdvana &raquo; Feed" href="https://nerdvanamedia.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nerdvana &raquo; Comments Feed" href="https://nerdvanamedia.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nerdvanamedia.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<style id='ugb-style-css-nodep-inline-css' type='text/css'>
/* Global typography */
.stk-block p, [data-block-type="core"] p, p[data-block-type="core"], [class*="wp-block-"] p, p[class*="wp-block-"], .ugb-main-block p, .stk-block li, [data-block-type="core"] li, li[data-block-type="core"], [class*="wp-block-"] li, li[class*="wp-block-"], .ugb-main-block li, .stk-block td, [data-block-type="core"] td, td[data-block-type="core"], [class*="wp-block-"] td, td[class*="wp-block-"], .ugb-main-block td { font-weight: ;text-transform: ; }
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.8.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='ugb-style-css-v2-css'  href='https://nerdvanamedia.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks/dist/deprecated/frontend_blocks_deprecated_v2.css?ver=3.0.7' type='text/css' media='all' />
<style id='ugb-style-css-v2-inline-css' type='text/css'>
:root {--stk-block-width-default-detected: 1320px;}
:root {
			--content-width: 1320px;
		}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.8.2/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.8.2/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='events-manager-css'  href='https://nerdvanamedia.com/wp-content/plugins/events-manager/includes/css/events_manager.css?ver=5.99912' type='text/css' media='all' />
<link rel='stylesheet' id='magic-liquidizer-table-style-css'  href='https://nerdvanamedia.com/wp-content/plugins/magic-liquidizer-responsive-table/idcss/ml-responsive-table.css?ver=2.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mks_shortcodes_simple_line_icons-css'  href='https://nerdvanamedia.com/wp-content/plugins/meks-flexible-shortcodes/css/simple-line/simple-line-icons.css?ver=1.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='mks_shortcodes_css-css'  href='https://nerdvanamedia.com/wp-content/plugins/meks-flexible-shortcodes/css/style.css?ver=1.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='extendify-sdk-utility-classes-css'  href='https://nerdvanamedia.com/wp-content/plugins/redux-framework/redux-core/extendify-sdk/public/build/extendify-utilities.css?ver=13.4' type='text/css' media='all' />
<link rel='stylesheet' id='herald-fonts-css'  href='https://fonts.googleapis.com/css?display=swap&family=Open+Sans%3A400%2C600%7CLato%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=2.5' type='text/css' media='all' />
<link rel='stylesheet' id='herald-main-css'  href='https://nerdvanamedia.com/wp-content/themes/herald/assets/css/min.css?ver=2.5' type='text/css' media='all' />
<style id='herald-main-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='herald_child_load_scripts-css'  href='https://nerdvanamedia.com/wp-content/themes/herald-child/style.css?ver=2.5' type='text/css' media='screen' />
<link rel='stylesheet' id='meks-author-widget-css'  href='https://nerdvanamedia.com/wp-content/plugins/meks-smart-author-widget/css/style.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='meks_ess-main-css'  href='https://nerdvanamedia.com/wp-content/plugins/meks-easy-social-share/assets/css/main.css?ver=1.2.6' type='text/css' media='all' />
<style id='meks_ess-main-inline-css' type='text/css'>

                body .meks_ess a {
                    background: #999999 !important;
                }
                body .meks_ess.transparent a::before, body .meks_ess.transparent a span, body .meks_ess.outline a span {
                    color: #999999 !important;
                }
                body .meks_ess.outline a::before {
                    color: #999999 !important;
                }
                body .meks_ess.outline a {
                    border-color: #999999 !important;
                }
                body .meks_ess.outline a:hover {
                    border-color: #999999 !important;
                }
            
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/10.4/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' id='ugb-block-frontend-js-v2-js-extra'>
/* <![CDATA[ */
var stackable = {"restUrl":"https:\/\/nerdvanamedia.com\/wp-json\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks/dist/deprecated/frontend_blocks_deprecated_v2.js?ver=3.0.7' id='ugb-block-frontend-js-v2-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/mouse.min.js' id='jquery-ui-mouse-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/sortable.min.js' id='jquery-ui-sortable-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/datepicker.min.js' id='jquery-ui-datepicker-js'></script>
<script type='text/javascript' id='jquery-ui-datepicker-js-after'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/menu.min.js' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/a11y.min.js' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/autocomplete.min.js' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/resizable.min.js' id='jquery-ui-resizable-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/draggable.min.js' id='jquery-ui-draggable-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/controlgroup.min.js' id='jquery-ui-controlgroup-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/checkboxradio.min.js' id='jquery-ui-checkboxradio-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/button.min.js' id='jquery-ui-button-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/dialog.min.js' id='jquery-ui-dialog-js'></script>
<script type='text/javascript' id='events-manager-js-extra'>
/* <![CDATA[ */
var EM = {"ajaxurl":"https:\/\/nerdvanamedia.com\/wp-admin\/admin-ajax.php","locationajaxurl":"https:\/\/nerdvanamedia.com\/wp-admin\/admin-ajax.php?action=locations_search","firstDay":"0","locale":"en","dateFormat":"mm\/dd\/yy","ui_css":"https:\/\/nerdvanamedia.com\/wp-content\/plugins\/events-manager\/includes\/css\/jquery-ui.min.css","show24hours":"0","is_ssl":"1","txt_search":"Search","txt_searching":"Searching...","txt_loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/plugins/events-manager/includes/js/events-manager.js?ver=5.99912' id='events-manager-js'></script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/plugins/magic-liquidizer-responsive-table/idjs/ml.responsive.table.min.js?ver=2.0.3' id='magic-liquidizer-table-js'></script>
<link rel="https://api.w.org/" href="https://nerdvanamedia.com/wp-json/" /><link rel="alternate" type="application/json" href="https://nerdvanamedia.com/wp-json/wp/v2/posts/156686" /><link rel='shortlink' href='https://wp.me/p7jz0b-ELc' />
<link rel="alternate" type="application/json+oembed" href="https://nerdvanamedia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nerdvanamedia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.17 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.gyofanc { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gyofanc img { height:auto; }
	.gyofanc-col { position:relative; float:left; }
	.gyofanc-col:first-child { margin-left: 0; }
	.gyofanc-col:last-child { margin-right: 0; }
	.gyofanc-2 {  width:100%; max-width:300px;  height:auto; margin: 0 auto; }
	.gyofanc-3 {  margin: 0 auto; }
	.gyofanc-5 {  margin: 0 auto; }
	.gyofanc-6 {  margin: 0 auto; }
	.gyofanc-15 { margin:0px 0px 15px 0px; }
	@media only screen and (max-width: 480px) {
		.gyofanc-col, .gyofanc-dyn, .gyofanc-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<meta name="generator" content="Site Kit by Google 1.47.0" /><meta name="framework" content="Redux 4.3.5" /><style type='text/css'>img#wpstats{display:none}</style>
		
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="apple-touch-icon" href="https://nerdvanamedia.com/meta/touch-icon-iphone.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://nerdvanamedia.com/meta/touch-icon-ipad.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://nerdvanamedia.com/meta/touch-icon-iphone-retina.png">
<link rel="apple-touch-icon" sizes="167x167" href="https://nerdvanamedia.com/meta/touch-icon-ipad-retina.png">
<meta name="apple-mobile-web-app-title" content="Nerdvana"><script data-ad-client="ca-pub-6506466664385944" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta property="fb:pages" content="56710126741" /><!--<link rel="stylesheet" type="text/css" href="/wp-content/themes/news-portal-pro-child/print.css" media="print">-->
<link rel="stylesheet" type="text/css" href="/wp-content/themes/herald-child/print.css" media="print"><!-- Google Analytics -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-53125597-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-53125597-1');
</script>

<!-- Amazon Mobile Popover -->
<script type="text/javascript">
    amzn_assoc_ad_type = "link_enhancement_widget";
    amzn_assoc_tracking_id = "nerdvana09-20";
    amzn_assoc_linkid = "79ff338262d987df86c0d5be96ef3ce0";
    amzn_assoc_placement = "";
    amzn_assoc_marketplace = "amazon";
    amzn_assoc_region = "US";
</script>
<script src="//ws-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&Operation=GetScript&ID=OneJS&WS=1&MarketPlace=US"></script><script async custom-element="amp-auto-ads"
        src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js">
</script><link rel="preconnect" href="https://fonts.googleapis.com">
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
<link href="https://fonts.googleapis.com/css2?display=swap&family=Libre+Franklin:wght@700&display=swap" rel="stylesheet">
<!-- Google AdSense snippet added by Site Kit -->
<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6506466664385944" crossorigin="anonymous" type="text/javascript"></script>

<!-- End Google AdSense snippet added by Site Kit -->
<style id="uagb-style-conditional-extension">@media (min-width: 1025px){body .uag-hide-desktop.uagb-google-map__wrap,body .uag-hide-desktop{display:none}}@media (min-width: 768px) and (max-width: 1024px){body .uag-hide-tab.uagb-google-map__wrap,body .uag-hide-tab{display:none}}@media (max-width: 767px){body .uag-hide-mob.uagb-google-map__wrap,body .uag-hide-mob{display:none}}</style><link rel="icon" href="https://nerdvanamedia.com/wp-content/uploads/2016/03/cropped-nerdvana512a-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://nerdvanamedia.com/wp-content/uploads/2016/03/cropped-nerdvana512a-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://nerdvanamedia.com/wp-content/uploads/2016/03/cropped-nerdvana512a-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://nerdvanamedia.com/wp-content/uploads/2016/03/cropped-nerdvana512a-1-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://nerdvanamedia.com/?custom-css=ff0e541181" /></head>

<body class="post-template-default single single-post postid-156686 single-format-standard wp-embed-responsive herald-v_2_5 herald-child">



	<header id="header" class="herald-site-header">

											<div class="header-top hidden-xs hidden-sm">
	<div class="container">
		<div class="row">
			<div class="col-lg-12">
				
												<div class="hel-l">
												<nav class="secondary-navigation herald-menu">	
		<ul id="menu-highlights" class="menu"><li id="menu-item-150928" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-150928"><a href="https://nerdvanamedia.com/news/">NERDVANA:</a></li>
<li id="menu-item-145461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145461"><a href="https://nerdvanamedia.com/dungeons-and-dragons/">D&#038;D</a></li>
<li id="menu-item-145047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145047"><a href="https://nerdvanamedia.com/the-skywalker-saga-celebrating-star-wars/">Star Wars</a></li>
<li id="menu-item-145044" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145044"><a href="https://nerdvanamedia.com/mandalorian/">The Mandalorian</a></li>
<li id="menu-item-145056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145056"><a href="https://nerdvanamedia.com/gaming/nintendo/">Nintendo</a></li>
<li id="menu-item-145045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145045"><a href="https://nerdvanamedia.com/video-game-release-dates/">Video game dates</a></li>
<li id="menu-item-155785" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155785"><a href="https://nerdvanamedia.com/about/">About Nerdvana</a></li>
<li id="menu-item-145259" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145259"><a href="https://nerdvanamedia.com/about/contributors/">Contributors</a></li>
<li id="menu-item-146086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146086"><a href="https://nerdvanamedia.com/services/">Services</a></li>
</ul>	</nav>
									</div>
				
												<div class="hel-r">
											<span class="site-description">Sci-Fi/Fantasy Media News &amp; Reviews Since 2007</span>									</div>
				
								
			</div>
		</div>
	</div>
</div>							<div class="header-middle herald-header-wraper hidden-xs hidden-sm">
	<div class="container">
		<div class="row">
				<div class="col-lg-12 hel-el">
				
															<div class="hel-l herald-go-ver">
													<div class="site-branding">
				<span class="site-title h1"><a href="https://nerdvanamedia.com/" rel="home"><img class="herald-logo no-lazyload" src="https://nerdvanamedia.com/wp-content/uploads/2020/05/nerdvana500x90airy3a.png" alt="Nerdvana"></a></span>
	</div>
											</div>
					
										
															<div class="hel-r herald-go-ver">
														<div class="herald-da hidden-xs"><a href="#main_content"></a><div class="gyofanc gyofanc-13"><div class="gyofanc-single ayofanc-6"><div class="skip-lazy"><a class="gofollow" data-track="NiwxMywxLDYw" href="http://bit.ly/samurailink" target="_top" rel="nofollow"><img id="samhed" style="border: 0px solid black; " src="https://nerdvanamedia.com/wp-content/uploads/2016/08/samurai728x90.jpg" alt="Samurai Comics" width="728" height="90" /></a></div></div></div></div>
											</div>
								
					
				
				</div>
		</div>
		</div>
</div>							<div class="header-bottom herald-header-wraper hidden-sm hidden-xs">
	<div class="container">
		<div class="row">
				<div class="col-lg-12 hel-el">
				
															<div class="hel-l">
													<nav class="main-navigation herald-menu">	
				<ul id="menu-main" class="menu"><li id="menu-item-144900" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144900"><a href="https://nerdvanamedia.com/sponsored/">Deals</a><li id="menu-item-144898" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144898"><a href="https://nerdvanamedia.com/sci-fi-fantasy/">Sci-Fi/Fantasy</a><li id="menu-item-144899" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-144899"><a href="https://nerdvanamedia.com/gaming/">Gaming</a><li id="menu-item-144901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144901"><a href="https://nerdvanamedia.com/movies/">Movies</a><li id="menu-item-144902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144902"><a href="https://nerdvanamedia.com/television/">Television</a><li id="menu-item-144903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144903"><a href="https://nerdvanamedia.com/comics/">Comics</a><li id="menu-item-144905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144905"><a href="https://nerdvanamedia.com/books/">Books</a><li id="menu-item-151158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151158"><a href="https://nerdvanamedia.com/event/">Events</a></ul>	</nav>													<div class="herald-menu-popup-search">
<span class="fa fa-search"></span>
	<div class="herald-in-popup">
		<form class="herald-search-form" action="https://nerdvanamedia.com/" method="get">
	<input name="s" class="herald-search-input" type="text" value="" placeholder="Search..." /><button type="submit" class="herald-search-submit"></button>
</form>	</div>
</div>											</div>
					
										
															<div class="hel-r">
															<ul id="menu-social-menu" class="herald-soc-nav"><li id="menu-item-113784" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113784"><a target="_blank" rel="noopener" href="https://www.facebook.com/nerdvanablog"><span class="herald-social-name">Facebook</span></a></li>
<li id="menu-item-113785" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113785"><a target="_blank" rel="noopener" href="http://twitter.com/nerdvana"><span class="herald-social-name">Twitter</span></a></li>
<li id="menu-item-113786" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113786"><a target="_blank" rel="noopener" href="https://www.instagram.com/nerdvanamedia"><span class="herald-social-name">Instagram</span></a></li>
<li id="menu-item-113787" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113787"><a target="_blank" rel="noopener" href="https://www.pinterest.com/nerdvanablog"><span class="herald-social-name">Pinterest</span></a></li>
<li id="menu-item-119605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119605"><a target="_blank" rel="noopener" href="https://www.linkedin.com/company/nerdvanamedia/"><span class="herald-social-name">LinkedIn</span></a></li>
<li id="menu-item-113790" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113790"><a target="_blank" rel="noopener" href="http://www.youtube.com/user/nerdvanablog"><span class="herald-social-name">YouTube</span></a></li>
</ul>											</div>
										
					
				
				</div>
		</div>
		</div>
</div>					
	</header>

			<div id="sticky-header" class="herald-header-sticky herald-header-wraper herald-slide hidden-xs hidden-sm">
	<div class="container">
		<div class="row">
				<div class="col-lg-12 hel-el">
				
															<div class="hel-l herald-go-hor">
													<div class="site-branding mini">
		<span class="site-title h1"><a href="https://nerdvanamedia.com/" rel="home"><img class="herald-logo-mini no-lazyload" src="https://nerdvanamedia.com/wp-content/uploads/2020/05/nerdvana-white-transp-150x23-1.png" alt="Nerdvana"></a></span>
</div>											</div>
					
										
															<div class="hel-r herald-go-hor">
													<nav class="main-navigation herald-menu">	
				<ul id="menu-main-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144900"><a href="https://nerdvanamedia.com/sponsored/">Deals</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144898"><a href="https://nerdvanamedia.com/sci-fi-fantasy/">Sci-Fi/Fantasy</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-144899"><a href="https://nerdvanamedia.com/gaming/">Gaming</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144901"><a href="https://nerdvanamedia.com/movies/">Movies</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144902"><a href="https://nerdvanamedia.com/television/">Television</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144903"><a href="https://nerdvanamedia.com/comics/">Comics</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144905"><a href="https://nerdvanamedia.com/books/">Books</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151158"><a href="https://nerdvanamedia.com/event/">Events</a></ul>	</nav>											</div>
										
					
				
				</div>
		</div>
		</div>
</div>	
	<div id="herald-responsive-header" class="herald-responsive-header herald-slide hidden-lg hidden-md">
	<div class="container">
		<div class="herald-nav-toggle"><i class="fa fa-bars"></i></div>
				<div class="site-branding mini">
		<span class="site-title h1"><a href="https://nerdvanamedia.com/" rel="home"><img class="herald-logo-mini no-lazyload" src="https://nerdvanamedia.com/wp-content/uploads/2020/05/nerdvana-white-transp-150x23-1.png" alt="Nerdvana"></a></span>
</div>
												<div class="herald-menu-popup-search">
<span class="fa fa-search"></span>
	<div class="herald-in-popup">
		<form class="herald-search-form" action="https://nerdvanamedia.com/" method="get">
	<input name="s" class="herald-search-input" type="text" value="" placeholder="Search..." /><button type="submit" class="herald-search-submit"></button>
</form>	</div>
</div>					
	</div>
</div>
<div class="herald-mobile-nav herald-slide hidden-lg hidden-md">
	<ul id="menu-main-2" class="herald-mob-nav"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144900"><a href="https://nerdvanamedia.com/sponsored/">Deals</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144898"><a href="https://nerdvanamedia.com/sci-fi-fantasy/">Sci-Fi/Fantasy</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-144899"><a href="https://nerdvanamedia.com/gaming/">Gaming</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144901"><a href="https://nerdvanamedia.com/movies/">Movies</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144902"><a href="https://nerdvanamedia.com/television/">Television</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144903"><a href="https://nerdvanamedia.com/comics/">Comics</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144905"><a href="https://nerdvanamedia.com/books/">Books</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151158"><a href="https://nerdvanamedia.com/event/">Events</a></ul>	
		
	
	
						<ul id="menu-social-menu-1" class="herald-soc-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113784"><a target="_blank" rel="noopener" href="https://www.facebook.com/nerdvanablog"><span class="herald-social-name">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113785"><a target="_blank" rel="noopener" href="http://twitter.com/nerdvana"><span class="herald-social-name">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113786"><a target="_blank" rel="noopener" href="https://www.instagram.com/nerdvanamedia"><span class="herald-social-name">Instagram</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113787"><a target="_blank" rel="noopener" href="https://www.pinterest.com/nerdvanablog"><span class="herald-social-name">Pinterest</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119605"><a target="_blank" rel="noopener" href="https://www.linkedin.com/company/nerdvanamedia/"><span class="herald-social-name">LinkedIn</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113790"><a target="_blank" rel="noopener" href="http://www.youtube.com/user/nerdvanablog"><span class="herald-social-name">YouTube</span></a></li>
</ul>		
</div>	
    	<div class="herald-da herald-slide herald-below-header"><div class="gyofanc gyofanc-1"><div class="gyofanc-single ayofanc-9"><div class="skip-lazy"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Leaderboard 728x90 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6506466664385944"
     data-ad-slot="2323969025"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div>
<a id="main_content"></a></div>

	<div id="content" class="herald-site-content herald-slide">

	


<div class="herald-section container ">

			<article id="post-156686" class="herald-single post-156686 post type-post status-publish format-standard has-post-thumbnail hentry category-events category-gaming category-rpg tag-dd tag-deborah-ann-woll tag-dungeons-dragons tag-dungeons-and-dragons tag-extra-life tag-gaten-matarazzo tag-jack-black tag-michelle-rodriguez">
			<div class="row">
								
			
<div class="col-lg-9 col-md-9 col-mod-single col-mod-main">
	
	<header class="entry-header">
		<h1 class="entry-title h1">Deborah Ann Woll leads Jack Black and more through D&#038;D&#8217;s Lost Odyssey: Promised Gold</h1>			<div class="entry-meta entry-meta-single"><div class="meta-item herald-date"><span class="updated">4 hours ago</span></div><div class="meta-item herald-author"><span class="vcard author"><span class="fn"><a href="https://nerdvanamedia.com/author/jaysonpeters/">Jayson Peters</a></span></span></div></div>
	</header>		
		<div class="row">

			

			<div class="col-lg-12 col-md-12 col-sm-12">
				<div class="entry-content herald-entry-content">

	
	
				<div class="herald-da herald-da-above-single"><div class="gyofanc gyofanc-6"><div class="gyofanc-single ayofanc-13"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Additional box -->
<ins class="adsbygoogle"
     style="display: block; margin-left: auto; margin-right: auto; background-color: transparent;"
     data-ad-client="ca-pub-6506466664385944"
     data-ad-slot="1706965001"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div>
	
					<div class="herald-share-content">
		<div class="meks_ess layout-5-1 transparent no-labels solid"><a href="#" onclick="return false;" class="meks_ess-item socicon-facebook" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F&amp;t=Deborah%20Ann%20Woll%20leads%20Jack%20Black%20and%20more%20through%20D%26D%E2%80%99s%20Lost%20Odyssey%3A%20Promised%20Gold"><span>Facebook</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-twitter" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F&amp;text=Deborah%20Ann%20Woll%20leads%20Jack%20Black%20and%20more%20through%20D%26D%E2%80%99s%20Lost%20Odyssey%3A%20Promised%20Gold"><span>Twitter</span></a><a href="#" onclick="return false;"  class="meks_ess-item socicon-pinterest" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F&amp;media=https%3A%2F%2Fnerdvanamedia.com%2Fwp-content%2Fuploads%2F2021%2F12%2Flost-odyssey-crop.jpg&amp;description=Deborah%20Ann%20Woll%20leads%20Jack%20Black%20and%20more%20through%20D%26D%E2%80%99s%20Lost%20Odyssey%3A%20Promised%20Gold"><span>Pinterest</span></a><a href="#" onclick="return false;"  class="meks_ess-item socicon-linkedin" data-url="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F"><span>LinkedIn</span></a><a href="mailto:?subject=Deborah%20Ann%20Woll%20leads%20Jack%20Black%20and%20more%20through%20D%26D%E2%80%99s%20Lost%20Odyssey%3A%20Promised%20Gold&amp;body=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F" class="meks_ess-item  socicon-mail prevent-share-popup "><span>Email</span></a></div>	</div>
		
	
<figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="1320" height="743" src="https://www.youtube.com/embed/xeCarOzV2Xg?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div></figure>



<h2 class="has-large-font-size">Dec. 20 is now D20 day!</h2>



<p data-block-type="core">It’s almost Dec. 20 and that can only mean one thing… D20 Day is happening on Monday!</p>



<p data-block-type="core">To celebrate, a brand new holiday-themed celebrity game featuring Jack Black, Michelle Rodriguez and other guests will premiere at 10 a.m. Pacific on Monday.  </p>



<p data-block-type="core">DM’ed by <a href="https://nerdvanamedia.com/gaming/rpg/deborah-ann-woll-true-blood-dungeon-master/135679/">Deborah Ann Woll</a>, <strong><em>Lost Odyssey: Promised Gold</em></strong> will have fans catching up with the adventures of Jack Black’s Barrolo after the end of <a href="https://nerdvanamedia.com/gaming/rpg/dungeons-dragons-live-2021-g4/151625/">his last D&amp;D adventure.</a> The game will raise money for <a href="https://dnd.wizards.com/extralife" target="_blank" rel="noreferrer noopener">Extra Life and the Children’s Miracle Network Hospitals</a>.</p>



<div class="wp-block-image" data-block-type="core"><figure class="alignright size-full"><img data-attachment-id="156689" data-permalink="https://nerdvanamedia.com/gaming/deborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold/156686/attachment/lost-odyssey-promised-gold/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/LOST-ODYSSEY-PROMISED-GOLD.jpg" data-orig-size="355,525" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LOST-ODYSSEY-PROMISED-GOLD" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/LOST-ODYSSEY-PROMISED-GOLD-203x300.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/LOST-ODYSSEY-PROMISED-GOLD.jpg" loading="lazy" width="355" height="525" src="https://nerdvanamedia.com/wp-content/uploads/2021/12/LOST-ODYSSEY-PROMISED-GOLD.jpg" alt="" class="wp-image-156689" srcset="https://nerdvanamedia.com/wp-content/uploads/2021/12/LOST-ODYSSEY-PROMISED-GOLD.jpg 355w, https://nerdvanamedia.com/wp-content/uploads/2021/12/LOST-ODYSSEY-PROMISED-GOLD-203x300.jpg 203w" sizes="(max-width: 355px) 100vw, 355px" /></figure></div>



<p data-block-type="core">The full cast list and their respective D&amp;D characters include:</p><div class="gyofanc gyofanc-12"><div class="gyofanc-single ayofanc-8"><div style="display: block; clear: both; margin-top: 5px !important; margin-bottom: 15px !important; margin-right: auto; margin-left: auto;"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Story -->
<ins class="adsbygoogle"
     style="display: block; margin-left: auto; margin-right: auto; background-color: transparent;"
     data-ad-client="ca-pub-6506466664385944"
     data-ad-slot="9330786310"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div>



<ul data-block-type="core"><li>Deborah Ann Woll – Dungeon Master</li><li>Gaten Matarazzo – Meryl Stroop (Half-Elf / Ranger Monk)</li><li>Jack Black – Barrolo (Mountain Dwarf / Warlock Bard)</li><li>Janina Gavankar – Zap (Human / Bard)</li><li>Melissa Villaseñor – Ruby (Rock Gnome / Druid)</li><li>Michelle Rodriguez – Lux (Dark Elf / Rogue)</li><li>Reggie Watts – Bronwyn (Wood Elf / Ranger)</li></ul>



<p data-block-type="core">In addition to the celebrity game, Wizards of the Coast is releasing a <strong>free adventure</strong> on Dec. 20 for fans and families alike to come together and embark on an epic quest over the holidays. The free adventure will be available on the <a href="https://dnd.wizards.com/products/essentials-kit" target="_blank" rel="noreferrer noopener">Essentials Kit product page</a> and <a href="https://dnd.wizards.com/remote/freematerial" target="_blank" rel="noreferrer noopener">Stay and Home Play at Home hub</a>.</p>



<p data-block-type="core">Lost Odyssey: Promised Gold will stream exclusively on <a href="https://www.tiktok.com/@ign?source=h5_t" target="_blank" rel="noreferrer noopener">IGN’s TikTok</a> channel at 10 a.m. PT on 12/20.</p>



<div class="wp-block-group" data-block-type="core" data-block-type="core"><div class="wp-block-group__inner-container">
<h4 class="hideyp">More Dungeons &amp; Dragons:</h4>


<p data-block-type="core"><div class="display-posts-listing grid"><div class="listing-item"><a class="image" href="https://nerdvanamedia.com/books/dragonlance-destinies-dragons-of-deceit/156660/"><img width="1200" height="675" src="https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop.jpg" class="attachment-large size-large wp-post-image" alt="Dragons of Deceit" loading="lazy" srcset="https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop.jpg 1200w, https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-300x168.jpg 300w, https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-990x557.jpg 990w, https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-470x264.jpg 470w, https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-640x360.jpg 640w, https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-414x232.jpg 414w, https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-215x120.jpg 215w, https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-560x315.jpg 560w" sizes="(max-width: 1200px) 100vw, 1200px" data-attachment-id="156661" data-permalink="https://nerdvanamedia.com/books/dragonlance-destinies-dragons-of-deceit/156660/attachment/dragons-of-deceit-crop/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop.jpg" data-orig-size="1200,675" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;lambada&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Dragons of Deceit" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-300x169.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop.jpg" /></a> <a class="title" href="https://nerdvanamedia.com/books/dragonlance-destinies-dragons-of-deceit/156660/">Dragonlance Destinies: Volume I &#8211; Dragons of Deceit announced for Aug. 9, 2022</a></div><div class="listing-item"><a class="image" href="https://nerdvanamedia.com/columns/wrapping-paper-gaming-grid/98016/"><img width="1024" height="768" src="https://nerdvanamedia.com/wp-content/uploads/2019/02/tabletop-rpg-setup-1024x768.jpg" class="attachment-large size-large wp-post-image" alt="tabletop rpg dungeons dragons dice polyhedral miniatures pencil paper" loading="lazy" srcset="https://nerdvanamedia.com/wp-content/uploads/2019/02/tabletop-rpg-setup-1024x768.jpg 1024w, https://nerdvanamedia.com/wp-content/uploads/2019/02/tabletop-rpg-setup-300x225.jpg 300w, https://nerdvanamedia.com/wp-content/uploads/2019/02/tabletop-rpg-setup-136x102.jpg 136w, https://nerdvanamedia.com/wp-content/uploads/2019/02/tabletop-rpg-setup-560x420.jpg 560w, https://nerdvanamedia.com/wp-content/uploads/2019/02/tabletop-rpg-setup.jpg 1106w" sizes="(max-width: 1024px) 100vw, 1024px" data-attachment-id="131958" data-permalink="https://nerdvanamedia.com/tabletop-rpg-setup/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2019/02/tabletop-rpg-setup.jpg" data-orig-size="1106,829" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9paulzhuk - stock.adobe.com&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tabletop rpg dungeons dragons dice polyhedral miniatures pencil paper" data-image-description="&lt;p&gt;tabletop rpg dungeons dragons dice polyhedral miniatures pencil paper&lt;/p&gt;
" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2019/02/tabletop-rpg-setup-300x225.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2019/02/tabletop-rpg-setup-1024x768.jpg" /></a> <a class="title" href="https://nerdvanamedia.com/columns/wrapping-paper-gaming-grid/98016/">Crafty gamers can deck dungeon halls with bargain wrapping paper</a></div><div class="listing-item"><a class="image" href="https://nerdvanamedia.com/gaming/rpg/fizban-strixhaven-book-delays/154363/"><img width="1200" height="792" src="https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos.jpg" class="attachment-large size-large wp-post-image" alt="Strixhaven: Curriculum of Chaos" loading="lazy" srcset="https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos.jpg 1200w, https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos-300x198.jpg 300w, https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos-130x86.jpg 130w, https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos-187x124.jpg 187w, https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos-990x653.jpg 990w, https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos-560x370.jpg 560w" sizes="(max-width: 1200px) 100vw, 1200px" data-attachment-id="152013" data-permalink="https://nerdvanamedia.com/strixhaven-curriculum-of-chaos/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos.jpg" data-orig-size="1200,792" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Strixhaven: Curriculum of Chaos" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos-300x198.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/06/strixhaven-curriculum-of-chaos.jpg" /></a> <a class="title" href="https://nerdvanamedia.com/gaming/rpg/fizban-strixhaven-book-delays/154363/">D&#038;D&#8217;s magical Strixhaven adventure sourcebook out after brief delay</a></div><div class="listing-item"><a class="image" href="https://nerdvanamedia.com/television/g4-dungeons-dragons-presents-invitation-to-party/155318/"><img width="1200" height="800" src="https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1.jpg" class="attachment-large size-large wp-post-image" alt="" loading="lazy" srcset="https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1.jpg 1200w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1-300x200.jpg 300w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1-414x276.jpg 414w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1-470x313.jpg 470w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1-640x426.jpg 640w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1-130x86.jpg 130w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1-187x124.jpg 187w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1-990x660.jpg 990w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1-560x373.jpg 560w" sizes="(max-width: 1200px) 100vw, 1200px" data-attachment-id="155333" data-permalink="https://nerdvanamedia.com/television/g4-dungeons-dragons-presents-invitation-to-party/155318/attachment/invitation-to-party-1/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1.jpg" data-orig-size="1200,800" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Invitation-to-Party-1" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1-300x200.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/11/Invitation-to-Party-1.jpg" /></a> <a class="title" href="https://nerdvanamedia.com/television/g4-dungeons-dragons-presents-invitation-to-party/155318/">D&#038;D comes to TV with G4&#8217;s &#8216;Invitation to Party&#8217;</a></div><div class="listing-item"><a class="image" href="https://nerdvanamedia.com/gaming/rpg/ed-greenwood-dungeons-dragons-endless-stair/155429/"><img width="535" height="392" src="https://nerdvanamedia.com/wp-content/uploads/2021/11/Dungeons-and-Dragons-CM8-The-Endless-Stair-1.jpg" class="attachment-large size-large wp-post-image" alt="Dungeons and Dragons CM8 The Endless Stair" loading="lazy" srcset="https://nerdvanamedia.com/wp-content/uploads/2021/11/Dungeons-and-Dragons-CM8-The-Endless-Stair-1.jpg 535w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Dungeons-and-Dragons-CM8-The-Endless-Stair-1-300x220.jpg 300w, https://nerdvanamedia.com/wp-content/uploads/2021/11/Dungeons-and-Dragons-CM8-The-Endless-Stair-1-74x55.jpg 74w" sizes="(max-width: 535px) 100vw, 535px" data-attachment-id="155435" data-permalink="https://nerdvanamedia.com/gaming/rpg/ed-greenwood-dungeons-dragons-endless-stair/155429/attachment/dungeons-and-dragons-cm8-the-endless-stair-1/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/11/Dungeons-and-Dragons-CM8-The-Endless-Stair-1.jpg" data-orig-size="535,392" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Dungeons and Dragons CM8 The Endless Stair" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/11/Dungeons-and-Dragons-CM8-The-Endless-Stair-1-300x220.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/11/Dungeons-and-Dragons-CM8-The-Endless-Stair-1.jpg" /></a> <a class="title" href="https://nerdvanamedia.com/gaming/rpg/ed-greenwood-dungeons-dragons-endless-stair/155429/">Forgotten Realms creator Ed Greenwood&#8217;s first D&#038;D RPG book is back in print</a></div><div class="listing-item"><a class="image" href="https://nerdvanamedia.com/gaming/rpg/dungeons-dragons-getting-started/135213/"><img width="1200" height="876" src="https://nerdvanamedia.com/wp-content/uploads/2019/06/dungeons-and-dragons-1200x876.jpg" class="attachment-large size-large wp-post-image" alt="Getting started with Dungeons &amp; Dragons" loading="lazy" srcset="https://nerdvanamedia.com/wp-content/uploads/2019/06/dungeons-and-dragons.jpg 1200w, https://nerdvanamedia.com/wp-content/uploads/2019/06/dungeons-and-dragons-300x219.jpg 300w, https://nerdvanamedia.com/wp-content/uploads/2019/06/dungeons-and-dragons-560x409.jpg 560w" sizes="(max-width: 1200px) 100vw, 1200px" data-attachment-id="135234" data-permalink="https://nerdvanamedia.com/gaming/rpg/dungeons-dragons-getting-started/135213/attachment/dungeons-and-dragons/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2019/06/dungeons-and-dragons.jpg" data-orig-size="1200,876" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Getting started with Dungeons &#038; Dragons" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2019/06/dungeons-and-dragons-300x219.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2019/06/dungeons-and-dragons-1200x876.jpg" /></a> <a class="title" href="https://nerdvanamedia.com/gaming/rpg/dungeons-dragons-getting-started/135213/">How to get started with Dungeons &#038; Dragons</a></div></div>
</div></div>



<div style="height:20px" aria-hidden="true" class="wp-block-spacer" data-block-type="core"></div>



<script type="text/javascript" data-block-type="core">
amzn_assoc_placement = "adunit0";
amzn_assoc_tracking_id = "nerdvana09-20";
amzn_assoc_ad_mode = "search";
amzn_assoc_ad_type = "smart";
amzn_assoc_marketplace = "amazon";
amzn_assoc_region = "US";
amzn_assoc_default_search_phrase = "dungeons dragons starter set";
amzn_assoc_default_category = "All";
amzn_assoc_linkid = "c2460c2490770fbc9bcb096866746ef0";
amzn_assoc_search_bar = "false";
amzn_assoc_search_bar_position = "top";
amzn_assoc_title = "Shop Related Products";
</script>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US"></script>



<p data-block-type="core"></p>

	
			<div class="meta-tags">
			<span>Tags</span><a href="https://nerdvanamedia.com/tag/dd/" rel="tag">D&amp;D</a> <a href="https://nerdvanamedia.com/tag/deborah-ann-woll/" rel="tag">Deborah Ann Woll</a> <a href="https://nerdvanamedia.com/tag/dungeons-dragons/" rel="tag">Dungeons &amp; Dragons</a> <a href="https://nerdvanamedia.com/tag/dungeons-and-dragons/" rel="tag">Dungeons and Dragons</a> <a href="https://nerdvanamedia.com/tag/extra-life/" rel="tag">extra life</a> <a href="https://nerdvanamedia.com/tag/gaten-matarazzo/" rel="tag">gaten matarazzo</a> <a href="https://nerdvanamedia.com/tag/jack-black/" rel="tag">Jack Black</a> <a href="https://nerdvanamedia.com/tag/michelle-rodriguez/" rel="tag">Michelle Rodriguez</a>		</div>
	
				<div class="herald-share-content">
		<div class="meks_ess layout-5-1 transparent no-labels solid"><a href="#" onclick="return false;" class="meks_ess-item socicon-facebook" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F&amp;t=Deborah%20Ann%20Woll%20leads%20Jack%20Black%20and%20more%20through%20D%26D%E2%80%99s%20Lost%20Odyssey%3A%20Promised%20Gold"><span>Facebook</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-twitter" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F&amp;text=Deborah%20Ann%20Woll%20leads%20Jack%20Black%20and%20more%20through%20D%26D%E2%80%99s%20Lost%20Odyssey%3A%20Promised%20Gold"><span>Twitter</span></a><a href="#" onclick="return false;"  class="meks_ess-item socicon-pinterest" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F&amp;media=https%3A%2F%2Fnerdvanamedia.com%2Fwp-content%2Fuploads%2F2021%2F12%2Flost-odyssey-crop.jpg&amp;description=Deborah%20Ann%20Woll%20leads%20Jack%20Black%20and%20more%20through%20D%26D%E2%80%99s%20Lost%20Odyssey%3A%20Promised%20Gold"><span>Pinterest</span></a><a href="#" onclick="return false;"  class="meks_ess-item socicon-linkedin" data-url="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F"><span>LinkedIn</span></a><a href="mailto:?subject=Deborah%20Ann%20Woll%20leads%20Jack%20Black%20and%20more%20through%20D%26D%E2%80%99s%20Lost%20Odyssey%3A%20Promised%20Gold&amp;body=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F" class="meks_ess-item  socicon-mail prevent-share-popup "><span>Email</span></a></div>	</div>
	
				<div class="herald-da"><!-- Begin Mailchimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<style type="text/css">
	#mc-embedded-subscribe-form input[type=checkbox]{display: inline; width: auto;margin-right: 10px;}
	#mergeRow-gdpr {margin-top: 20px;}
	#mergeRow-gdpr fieldset label {font-weight: normal;}
	#mc-embedded-subscribe-form .mc_fieldset{border:none;min-height: 0px;padding-bottom:0px;}
</style>
<div id="mc_embed_signup">
<form action="https://nerdvanamedia.us6.list-manage.com/subscribe/post?u=4e8c3d55b0caa9ba0841108e3&amp;id=e48fb320c9" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2>Subscribe for free updates!</h2>
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address </label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group input-group">
    <strong>Newsletters </strong>
    <ul><li><input type="checkbox" value="1" name="group[21101][1]" id="mce-group[21101]-21101-0"><label for="mce-group[21101]-21101-0">Nerdvana: Sci-fi &amp; Fantasy, Video Games, News &amp; Reviews</label></li>
<li><input type="checkbox" value="2" name="group[21101][2]" id="mce-group[21101]-21101-1"><label for="mce-group[21101]-21101-1">Pueblo (CO) Local News &amp; Events</label></li>
<li><input type="checkbox" value="4" name="group[21101][4]" id="mce-group[21101]-21101-2"><label for="mce-group[21101]-21101-2">All the Deals!</label></li>
</ul>
</div>
<p><a href="https://us6.campaign-archive.com/home/?u=4e8c3d55b0caa9ba0841108e3&id=e48fb320c9" title="View previous campaigns">View previous campaigns.</a></p>
<p>Powered by <a href="http://eepurl.com/g7KXOL" title="MailChimp - email marketing made easy and fun">MailChimp</a></p>
<div id="mergeRow-gdpr" class="mergeRow gdpr-mergeRow content__gdprBlock mc-field-group">
    <div class="content__gdpr">
        <label>Marketing Permissions</label>
        <p>Nerdvana Media will use the information you provide on this form to be in touch with you and to provide updates and marketing. Please let us know all the ways you would like to hear from us:</p>
        <fieldset class="mc_fieldset gdprRequired mc-field-group" name="interestgroup_field">
		<label class="checkbox subfield" for="gdpr_2201"><input type="checkbox" id="gdpr_2201" name="gdpr[2201]" value="Y" class="av-checkbox "><span>Email</span> </label>
        </fieldset>
        <p>You can change your mind at any time by clicking the unsubscribe link in the footer of any email you receive from us, or by contacting us at news@nerdvanamedia.com. We will treat your information with respect. For more information about our privacy practices please visit our website. By clicking below, you agree that we may process your information in accordance with these terms.</p>
    </div>
    <div class="content__gdprLegal">
        <p>We use Mailchimp as our marketing platform. By clicking below to subscribe, you acknowledge that your information will be transferred to Mailchimp for processing. <a href="https://mailchimp.com/legal/" target="_blank">Learn more about Mailchimp's privacy practices here.</a></p>
    </div>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_4e8c3d55b0caa9ba0841108e3_e48fb320c9" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup-->

<!--<div id="match-mail" style="margin-bottom: 10px !important;">-->
<!--<div class="herald-mod-wrap" style="display: block !important; clear: both !important;"><div class="herald-mod-head" style="float: left; text-align: left; margin-top: 15px;"><div class="herald-mod-title"><h4 class="h6 herald-mod-h herald-color">Here and there ...</h4></div></div></div>-->
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-6506466664385944"
     data-ad-slot="9611424316"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<!--
</div> -->
<div id="amzn-assoc-ad-98f4751a-f520-48ec-b95a-7f3e3b87cba5"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=98f4751a-f520-48ec-b95a-7f3e3b87cba5"></script></div>
	</div>			</div>

			<div id="extras" class="col-lg-12 col-md-12 col-sm-12">
				


			</div>

		</div>

</div>

	

	<div class="herald-sidebar col-lg-3 col-md-3 herald-sidebar-right">

					<div id="herald_posts_widget-16" class="widget herald_posts_widget"><h4 class="widget-title h6"><span>Latest</span></h4>
		
		<div class="row ">

							<article class="herald-lay-g post-156660 post type-post status-publish format-standard has-post-thumbnail hentry category-books category-sci-fi-fantasy tag-dd tag-dragonlance tag-dungeons-dragons tag-dungeons-and-dragons tag-margaret-weis tag-tracy-hickman">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/books/dragonlance-destinies-dragons-of-deceit/156660/" title="Dragonlance Destinies: Volume I &#8211; Dragons of Deceit announced for Aug. 9, 2022">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-74x55.jpg" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="Dragons of Deceit" loading="lazy" data-attachment-id="156661" data-permalink="https://nerdvanamedia.com/books/dragonlance-destinies-dragons-of-deceit/156660/attachment/dragons-of-deceit-crop/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop.jpg" data-orig-size="1200,675" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;lambada&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Dragons of Deceit" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop-300x169.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Dragons-of-Deceit-crop.jpg" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/books/dragonlance-destinies-dragons-of-deceit/156660/">Dragonlance Destinies: Volume I &#8211; Dragons of Deceit announced for Aug. 9, 2022</a></h2>
			</div>
</div>

</div>
</article>							<article class="herald-lay-g post-156648 post type-post status-publish format-standard has-post-thumbnail hentry category-sci-fi-fantasy category-television tag-audio tag-audio-drama tag-audio-dramas tag-big-finish tag-big-finish-productions tag-bonnie-langford tag-casting tag-colin-baker tag-doctor-who tag-russell-t-davies tag-sixth-doctor">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/sci-fi-fantasy/cover-artwork-guest-cast-revealed-for-russell-t-davies-doctor-who-audio-drama/156648/" title="Cover artwork, guest cast revealed for Russell T Davies&#8217; Doctor Who audio drama">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2021/12/DWLSSP01_mindofthehodiac_crop-74x55.jpg" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="Doctor Who: Mind of the Hodiac" loading="lazy" data-attachment-id="156649" data-permalink="https://nerdvanamedia.com/sci-fi-fantasy/cover-artwork-guest-cast-revealed-for-russell-t-davies-doctor-who-audio-drama/156648/attachment/dwlssp01_mindofthehodiac_crop/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/DWLSSP01_mindofthehodiac_crop.jpg" data-orig-size="1417,797" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Doctor Who: Mind of the Hodiac" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/DWLSSP01_mindofthehodiac_crop-300x169.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/DWLSSP01_mindofthehodiac_crop-1200x675.jpg" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/sci-fi-fantasy/cover-artwork-guest-cast-revealed-for-russell-t-davies-doctor-who-audio-drama/156648/">Cover artwork, guest cast revealed for Russell T Davies&#8217; Doctor Who audio drama</a></h2>
			</div>
</div>

</div>
</article>							<article class="herald-lay-g post-156669 post type-post status-publish format-standard has-post-thumbnail hentry category-general tag-nintendo tag-nintendo-switch tag-nintendo-switch-online tag-sega tag-sega-genesis">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/general/sega-genesis-altered-beast-nintendo-switch/156669/" title="Altered Beast, Toejam &#038; Earl and more join SEGA Genesis games on Nintendo Switch">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2021/12/Altered-Beast-crop-74x55.jpg" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="Altered Beast" loading="lazy" data-attachment-id="156675" data-permalink="https://nerdvanamedia.com/general/sega-genesis-altered-beast-nintendo-switch/156669/attachment/altered-beast-crop/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Altered-Beast-crop.jpg" data-orig-size="755,425" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Altered Beast" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Altered-Beast-crop-300x169.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Altered-Beast-crop.jpg" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/general/sega-genesis-altered-beast-nintendo-switch/156669/">Altered Beast, Toejam &#038; Earl and more join SEGA Genesis games on Nintendo Switch</a></h2>
			</div>
</div>

</div>
</article>							<article class="herald-lay-g post-156637 post type-post status-publish format-standard has-post-thumbnail hentry category-television tag-betty-white tag-digital-media tag-digital-video tag-don-cheadle tag-hulu tag-spinoff tag-spinoffs tag-streaming">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/television/golden-palace-hulu/156637/" title="Golden Girls spinoff Golden Palace coming to Hulu Jan. 10">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2021/12/GLDNPALCE_Y1_GAL_Image001_L-74x55.jpg" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="THE GOLDEN PALACE" loading="lazy" data-attachment-id="156639" data-permalink="https://nerdvanamedia.com/television/golden-palace-hulu/156637/attachment/gldnpalce_y1_gal_image001_l/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/GLDNPALCE_Y1_GAL_Image001_L.jpg" data-orig-size="1200,803" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="THE GOLDEN PALACE" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/GLDNPALCE_Y1_GAL_Image001_L-300x201.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/GLDNPALCE_Y1_GAL_Image001_L.jpg" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/television/golden-palace-hulu/156637/">Golden Girls spinoff Golden Palace coming to Hulu Jan. 10</a></h2>
			</div>
</div>

</div>
</article>							<article class="herald-lay-g post-156626 post type-post status-publish format-standard has-post-thumbnail hentry category-movies tag-alfred-molina tag-benedict-cumberbatch tag-chris-mckenna tag-comic-book-movies tag-doctor-strange tag-erik-sommers tag-film-review tag-film-reviews tag-j-k-simmons tag-jacob-batalon tag-jamie-foxx tag-jon-favreau tag-jon-watts tag-marisa-tomei tag-marvel tag-marvel-cinematic-universe tag-marvel-comics tag-mcu tag-movie-review-2 tag-movie-review tag-no-way-home tag-review-2 tag-reviews tag-spider-man tag-spider-man-no-way-home tag-stan-lee tag-steve-ditko tag-tom-holland tag-willem-dafoe tag-zendaya">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/movies/spider-man-no-way-home-spoiler-free-review/156626/" title="Spider-Man: No Way Home (spoiler-free review)">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2021/12/Spider-Man-No-Way-Home-74x55.jpg" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="Spider-Man: No Way Home" loading="lazy" data-attachment-id="156627" data-permalink="https://nerdvanamedia.com/movies/spider-man-no-way-home-spoiler-free-review/156626/attachment/spider-man-no-way-home-3/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Spider-Man-No-Way-Home.jpg" data-orig-size="800,422" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Spider-Man: No Way Home" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Spider-Man-No-Way-Home-300x158.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Spider-Man-No-Way-Home.jpg" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/movies/spider-man-no-way-home-spoiler-free-review/156626/">Spider-Man: No Way Home (spoiler-free review)</a></h2>
			</div>
</div>

</div>
</article>							<article class="herald-lay-g post-156616 post type-post status-publish format-standard has-post-thumbnail hentry category-movies tag-digital-media tag-digital-video tag-disney-2 tag-ryan-reynolds tag-streaming">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/movies/free-guy-streaming-on-disney-feb-23/156616/" title="Free Guy streaming on Disney+ Feb. 23">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2019/12/free-guy.png" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="Free Guy" loading="lazy" data-attachment-id="140275" data-permalink="https://nerdvanamedia.com/movies/free-guy-ryan-reynolds-trailer/140273/attachment/free-guy/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2019/12/free-guy.png" data-orig-size="455,342" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Free Guy" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2019/12/free-guy-300x225.png" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2019/12/free-guy.png" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/movies/free-guy-streaming-on-disney-feb-23/156616/">Free Guy streaming on Disney+ Feb. 23</a></h2>
			</div>
</div>

</div>
</article>							<article class="herald-lay-g post-156598 post type-post status-publish format-standard has-post-thumbnail hentry category-movies tag-4k-ultra-high-definition tag-blu-ray tag-blu-rays tag-bluray tag-dvd tag-dvd-release tag-dvds tag-eternals tag-marvel-cinematic-universe tag-marvel-studios tag-mcu">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/movies/marvel-studios-eternals-digital-4k-bluray-dvd/156598/" title="Marvel Studios’ Eternals on digital Jan. 12 and 4K Ultra HD, Blu-ray and DVD Feb. 15">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2021/11/Eternals_01-74x55.jpg" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="The Eternals" loading="lazy" data-attachment-id="155033" data-permalink="https://nerdvanamedia.com/movies/eternals-review/155030/attachment/eternals_01/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/11/Eternals_01.jpg" data-orig-size="1611,675" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9Marvel Studios 2021. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The Eternals" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/11/Eternals_01-300x126.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/11/Eternals_01-1200x503.jpg" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/movies/marvel-studios-eternals-digital-4k-bluray-dvd/156598/">Marvel Studios’ Eternals on digital Jan. 12 and 4K Ultra HD, Blu-ray and DVD Feb. 15</a></h2>
			</div>
</div>

</div>
</article>							<article class="herald-lay-g post-154116 post type-post status-publish format-standard has-post-thumbnail hentry category-sci-fi-fantasy category-television tag-audio tag-audio-drama tag-audio-dramas tag-big-finish tag-big-finish-productions tag-doctor-who tag-freema-agyeman tag-marina-sirtis">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/sci-fi-fantasy/the-year-of-martha-jones-details/154116/" title="The Year of Martha Jones brings Trek star Marina Sirtis&#8217; Doctor Who debut">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2021/08/MARTHA01_slipcase_cropped-74x55.jpg" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="The Year of Martha Jones from Big Finish Productions" loading="lazy" data-attachment-id="153474" data-permalink="https://nerdvanamedia.com/sci-fi-fantasy/marina-sirtis-doctor-who-year-of-martha-jones/153473/attachment/martha01_slipcase_cropped/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/08/MARTHA01_slipcase_cropped.jpg" data-orig-size="1200,699" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The Year of Martha Jones from Big Finish Productions" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/08/MARTHA01_slipcase_cropped-300x175.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/08/MARTHA01_slipcase_cropped.jpg" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/sci-fi-fantasy/the-year-of-martha-jones-details/154116/">The Year of Martha Jones brings Trek star Marina Sirtis&#8217; Doctor Who debut</a></h2>
			</div>
</div>

</div>
</article>							<article class="herald-lay-g post-156576 post type-post status-publish format-standard has-post-thumbnail hentry category-comics category-sci-fi-fantasy tag-critical-role tag-dark-horse tag-dark-horse-comics tag-graphic-novel tag-graphic-novels">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/sci-fi-fantasy/dark-horse-graphic-novels-collecting-critical-role/156576/" title="Dark Horse releasing 2 new graphic novels collecting ongoing Critical Role comic series">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2021/12/Critical-Role-Vox-Machina-Origins-Series-III-crop-74x55.jpg" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="Critical Role Vox Machina Origins Series III" loading="lazy" data-attachment-id="156554" data-permalink="https://nerdvanamedia.com/critical-role-vox-machina-origins-series-iii-crop/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Critical-Role-Vox-Machina-Origins-Series-III-crop.jpg" data-orig-size="1200,675" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Critical Role Vox Machina Origins Series III" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Critical-Role-Vox-Machina-Origins-Series-III-crop-300x169.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/Critical-Role-Vox-Machina-Origins-Series-III-crop.jpg" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/sci-fi-fantasy/dark-horse-graphic-novels-collecting-critical-role/156576/">Dark Horse releasing 2 new graphic novels collecting ongoing Critical Role comic series</a></h2>
			</div>
</div>

</div>
</article>							<article class="herald-lay-g post-156559 post type-post status-publish format-standard has-post-thumbnail hentry category-gaming category-nintendo category-rpg category-switch tag-indie-games tag-indie-rpg">
<div class="row">	
		
		<div class="col-lg-4 col-xs-3">
		<div class="herald-post-thumbnail">
			<a href="https://nerdvanamedia.com/gaming/sea-of-stars-the-messenger-turn-based-rpg-prequel-nintendo-switch-2022-holiday/156559/" title="Sea of Stars, The Messenger&#8217;s turn-based RPG prequel, coming to Nintendo Switch for 2022 holiday season">
				<img width="74" height="55" src="https://nerdvanamedia.com/wp-content/uploads/2021/12/NintendoSwitch_SeaofStars_cropped-74x55.jpg" class="attachment-herald-lay-g1 size-herald-lay-g1 wp-post-image" alt="Sea of Stars" loading="lazy" data-attachment-id="156558" data-permalink="https://nerdvanamedia.com/nintendoswitch_seaofstars_cropped/" data-orig-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/NintendoSwitch_SeaofStars_cropped.jpg" data-orig-size="1000,634" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Sea of Stars" data-image-description="" data-image-caption="" data-medium-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/NintendoSwitch_SeaofStars_cropped-300x190.jpg" data-large-file="https://nerdvanamedia.com/wp-content/uploads/2021/12/NintendoSwitch_SeaofStars_cropped.jpg" />			</a>
		</div>
	</div>
		
<div class="col-lg-8 col-xs-9 herald-no-pad">
	<div class="entry-header">
		
		<h2 class="entry-title h7"><a href="https://nerdvanamedia.com/gaming/sea-of-stars-the-messenger-turn-based-rpg-prequel-nintendo-switch-2022-holiday/156559/">Sea of Stars, The Messenger&#8217;s turn-based RPG prequel, coming to Nintendo Switch for 2022 holiday season</a></h2>
			</div>
</div>

</div>
</article>			
		</div>

		
		
		</div>		
					<div class="herald-sticky">
				<div id="5eda9db87962c-11" class="widget 5eda9db87962c"><div class="gyofanc gyofanc-14"><div class="gyofanc-single ayofanc-7"><div class="skip-lazy"><a class="gofollow" data-track="NywxNCwxLDYw" href="http://bit.ly/samurailink" target="_top" rel="nofollow"><img src="https://nerdvanamedia.com/wp-content/uploads/2021/11/samurai-300x600small-new.png" style="border: 1px solid black; width: 100%; max-width: 300px; display: block; margin-left: auto; margin-right: auto;" alt="Samurai Comics"></a></div></div></div></div>			</div>
		
	</div>


			</div>	
		</article>
	</div>


	</div>

    	<div class="herald-da herald-slide herald-above-footer"><div class="gyofanc gyofanc-1"><div class="gyofanc-single ayofanc-216"><div class="skip-lazy"><a href="https://www.dmsguild.com/browse.php?filters=100084&site=dmg&src=van_richten?&affiliate_id=53019"><img src="https://www.dmsguild.com/themes/dmg/images/DMG-VRbanner.png" border="0" alt="" style="width: 100%; max-width: 728px; display: block; margin-right: auto; margin-left: auto;" /></a></div></div></div></div>

	<footer id="footer" class="herald-site-footer herald-slide">

		
					<div class="footer-bottom">
<div class="container">
	<div class="row">
		<div class="col-lg-12">
			
									<div class="hel-l herald-go-hor">
											<ul id="menu-social-menu-2" class="herald-soc-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113784"><a target="_blank" rel="noopener" href="https://www.facebook.com/nerdvanablog"><span class="herald-social-name">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113785"><a target="_blank" rel="noopener" href="http://twitter.com/nerdvana"><span class="herald-social-name">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113786"><a target="_blank" rel="noopener" href="https://www.instagram.com/nerdvanamedia"><span class="herald-social-name">Instagram</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113787"><a target="_blank" rel="noopener" href="https://www.pinterest.com/nerdvanablog"><span class="herald-social-name">Pinterest</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119605"><a target="_blank" rel="noopener" href="https://www.linkedin.com/company/nerdvanamedia/"><span class="herald-social-name">LinkedIn</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113790"><a target="_blank" rel="noopener" href="http://www.youtube.com/user/nerdvanablog"><span class="herald-social-name">YouTube</span></a></li>
</ul>							</div>
			
									<div class="hel-r herald-go-hor">
									<div class="herald-copyright">Copyright &copy; 2021 Nerdvana Media<!--. Created by <a href="#" target="_blank">Meks</a>. Powered by <a href="http://www.wordpress.org" target="_blank">WordPress</a>.--></div>
							</div>
			
									<div class="hel-c herald-go-hor">
									<nav class="secondary-navigation herald-menu">	
		<ul id="menu-footer-center" class="menu"><li id="menu-item-155724" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155724"><a href="https://nerdvanamedia.com/about/">About</a></li>
<li id="menu-item-145165" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145165"><a href="https://nerdvanamedia.com/about/contact/">Contact</a></li>
<li id="menu-item-145548" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145548"><a href="https://nerdvanamedia.com/support/">Help</a></li>
</ul></nav>
							</div>
			
		</div>
	</div>
</div>
</div>	    
	</footer>

			<a href="javascript:void(0)" id="back-top" class="herald-goto-top"><i class="fa fa-angle-up"></i></a>
	


<script type='text/javascript'>
	//<![CDATA[
    jQuery(document).ready(function($) { 
    	$('html').MagicLiquidizerTable({ whichelement: 'table', breakpoint: '728', headerSelector: 'thead td, thead th, tr th', bodyRowSelector: 'tbody tr, tr', table: '1' })
    })
	//]]>
</script> 	
<script>requestAnimationFrame(() => document.body.classList.add( "stk--anim-init" ))</script><amp-auto-ads type="adsense"
        data-ad-client="ca-pub-6506466664385944">
</amp-auto-ads>		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		<script type='text/javascript' id='adrotate-dyngroup-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/nerdvanamedia.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js' id='adrotate-dyngroup-js'></script>
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/nerdvanamedia.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' id='flying-pages-js-before'>
window.FPConfig= {
	delay: 0,
	ignoreKeywords: ["\/wp-admin","\/wp-login.php","\/cart","add-to-cart","logout","#","?",".png",".jpeg",".jpg",".gif",".svg"],
	maxRPS: 3,
    hoverDelay: 50
};
</script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/plugins/flying-pages/flying-pages.min.js?ver=2.4.2' id='flying-pages-js' defer></script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/plugins/meks-flexible-shortcodes/js/main.js?ver=1' id='mks_shortcodes_js-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js'></script>
<script type='text/javascript' id='herald-main-js-extra'>
/* <![CDATA[ */
var herald_js_settings = {"ajax_url":"https:\/\/nerdvanamedia.com\/wp-admin\/admin-ajax.php","rtl_mode":"false","header_sticky":"1","header_sticky_offset":"300","header_sticky_up":"","single_sticky_bar":"","popup_img":"","logo":"https:\/\/nerdvanamedia.com\/wp-content\/uploads\/2020\/05\/nerdvana500x90airy3a.png","logo_retina":"https:\/\/nerdvanamedia.com\/wp-content\/uploads\/2016\/05\/nerdvana90ht.png","logo_mini":"https:\/\/nerdvanamedia.com\/wp-content\/uploads\/2020\/05\/nerdvana-white-transp-150x23-1.png","logo_mini_retina":"https:\/\/nerdvanamedia.com\/wp-content\/uploads\/2020\/05\/nerdvana-white-transp-662x100-1.png","smooth_scroll":"","trending_columns":"4","responsive_menu_more_link":"0","header_ad_responsive":"1","header_responsive_breakpoint":"1200"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/themes/herald/assets/js/min.js?ver=2.5' id='herald-main-js'></script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/plugins/meks-easy-social-share/assets/js/main.js?ver=1.2.6' id='meks_ess-main-js'></script>
<script type='text/javascript' src='https://nerdvanamedia.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.5' id='page-links-to-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/nerdvanamedia.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/nerdvanamedia.com\/wp-admin\/admin-ajax.php","nonce":"b0d11227c8","display_exif":"0","display_comments":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/nerdvanamedia.com\/wp-login.php?redirect_to=https%3A%2F%2Fnerdvanamedia.com%2Fgaming%2Fdeborah-ann-woll-leads-jack-black-and-more-through-dds-lost-odyssey-promised-gold%2F156686%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.4/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script type="text/javascript" id="flying-scripts">const loadScriptsTimer=setTimeout(loadScripts,5*1000);const userInteractionEvents=["mouseover","keydown","touchstart","touchmove","wheel"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){loadScripts();clearTimeout(loadScriptsTimer);userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}
function loadScripts(){document.querySelectorAll("script[data-type='lazy']").forEach(function(elem){elem.setAttribute("src",elem.getAttribute("data-src"))})}</script>
    <!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.gyofanc-2').gslider({groupid:2,speed:10000,repeat_impressions:'Y'});
}});
</script>
<!-- /AdRotate JS -->

<script src='https://stats.wp.com/e-202150.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.4',blog:'108097135',post:'156686',tz:'-7',srv:'nerdvanamedia.com'} ]);
	_stq.push([ 'clickTrackerInit', '108097135', '156686' ]);
</script>

</body>
</html>
<!-- Dynamic page generated in 0.449 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-12-17 10:49:39 -->

<!-- Compression = gzip -->